Amazon Advertising Data Sync Degradation

Incident Report for Skai

Resolved

The issue affecting campaign sync and BDS downloads has been fully resolved. All processes are running normally.
Please note that as part of our investigation, Amazon negative targeting has been temporarily disabled. We are working with Amazon to investigate the root cause and will provide a further update once it has been reinstated.
Thank you for your patience.
Posted Aug 01, 2026 - 16:29 UTC

Monitoring

We have identified the root cause as an issue with the Amazon Advertising API. We have implemented a workaround and are currently monitoring to confirm full recovery. We will provide a further update shortly.
Posted Aug 01, 2026 - 14:58 UTC

Investigating

We are currently investigating an issue affecting Amazon Advertising campaign data synchronization. Some processes may be delayed as a result.

Our investigation points to an issue on Amazon's side. We have escalated to Amazon and are actively working towards resolution.
Posted Aug 01, 2026 - 11:04 UTC
This incident affected: Pivot - DO NOT DELETE (Amazon), Data (Amazon), Optimization (Amazon), and Automated Actions (Amazon).