Microsoft Reporting API delays 2025-08-04

Incident Report for Skai

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 02:57 UTC

Monitoring

Daily reports have been processed successfully. We will continue to monitor.
Posted Aug 04, 2025 - 16:48 UTC

Identified

Ever since yesterday (Sunday, August 3rd) afternoon, Microsoft Ads are experiencing delays in their reporting and API.
They have acknowledged that and even posted that in their status page: https://status.ads.microsoft.com/
Posted Aug 04, 2025 - 12:32 UTC
This incident affected: Data (Microsoft), Reports (Microsoft), Optimization (Microsoft), and Automated Actions (Microsoft).