Amazon AWS experiencing outage

Incident Report for Skai

Identified

AWS experienced a power issue in one of their US-East data centres, which caused some servers and storage systems to shut down unexpectedly. During recovery, cooling systems in that area were also affected, so AWS has had to restore services gradually and carefully to avoid further disruption.

Due to this, we are continuing to see a small number of servers remain unavailable. Our engineers are making every effort to restore full service as quickly as possible once AWS has completed recovery activities.

Amazon AWS Status Page: https://health.aws.amazon.com/health/status
Posted May 08, 2026 - 08:46 UTC

Investigating

AWS is currently experiencing a major outage affecting the US-East-1 region, which began at approximately 8:30 PM EST. AWS engineers are actively working to restore the affected services.

As a result, our platform is experiencing intermittent issues across a small number of servers. Our engineering team is actively working to restore full service as quickly as possible.

AWS Status Page: https://health.aws.amazon.com/health/status
Posted May 08, 2026 - 05:15 UTC
This incident affects: Optimization (Google, Microsoft, Amazon, Walmart, Meta, Amazon DSP, Pinterest, Apple Search Ads, Criteo, Sam's Club, Citrus Ads, PromoteIQ, Instacart, LinkedIn, Snapchat, TikTok) and Platform Availability (Google, Microsoft, Amazon, Walmart, Meta, Amazon DSP, Pinterest, Apple Search Ads, Criteo, Sam's Club, Citrus Ads, PromoteIQ, Instacart, LinkedIn, Snapchat, TikTok).