Microsoft Advertising Data Delay

Incident Report for Skai

Resolved

This incident has been resolved.
Posted Apr 30, 2025 - 00:20 UTC

Investigating

A Microsoft Advertising API issue is causing delays in receiving performance data reports. We have escalated the issue with Microsoft's team.
Posted Apr 29, 2025 - 17:53 UTC
This incident affected: Data (Microsoft), Reports (Microsoft), and Optimization (Microsoft).