Amazon - Inflated Performance Metrics 23rd June

Incident Report for Skai

Resolved

The issue is Resolved. Data for 23rd June was corrected on all affected servers.
Posted Jun 25, 2025 - 15:07 UTC

Identified

Our engineers have identified the issue and are working to correct the data for 23rd June. Intra day data will be fixed retroactively.
Posted Jun 24, 2025 - 19:51 UTC

Investigating

We are aware that some clients are seeing inflated Amazon performance metrics for 23rd June.

Our engineering team is currently investigating the issue.
Posted Jun 24, 2025 - 17:11 UTC
This incident affected: Data (Amazon), Reports (Amazon), and Optimization (Amazon).