A backlog of Amazon performance reports remains on our side. We are actively monitoring and processing these reports to ensure normal operations are fully restored.
Posted Oct 20, 2025 - 23:23 UTC
Update
We are continuing to monitor for any further issues.
We are actively monitoring the situation while awaiting a full resolution from Amazon.
We are still experiencing delays in Amazon Performance data being received due to the ongoing incident. Data is continuing to process, albeit more slowly than usual.
Some users may notice slower performance when loading analysis grids; this can often be resolved by refreshing the page.
A few users have encountered intermittent “Internal 500” errors. If this occurs, please try again after a short interval.
We hope Amazon will resolve the underlying issue soon to restore normal service levels.
Posted Oct 20, 2025 - 18:42 UTC
Monitoring
AWS experienced a major outage at around 3 AM EST, centered on the US-East-1 region. The disruption impacted a wide range of major apps, websites, and services globally. The outage lasted roughly three hours, with most services now reported as fully mitigated. AWS Status page: https://health.aws.amazon.com/health/status
Our platform is fully operational for all clients.
Performance data has already begun to recover automatically, and any processes waiting for daily data will resume as soon as the data becomes available. Our teams continue to monitor the situation closely to ensure there is no further impact.
Posted Oct 20, 2025 - 14:22 UTC
This incident affected: Data (Amazon, Amazon DSP, Criteo) and Platform Availability (Amazon, Amazon DSP, Criteo).