Microsoft Advertising data delay

Incident Report for Skai

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 18:26 UTC

Monitoring

The issue was resoled by Microsoft and the reports are coming in. We will continue to monitor.
Posted Dec 04, 2025 - 17:21 UTC

Investigating

Starting this morning at 2 am EST, Microsoft Ads are experiencing delays in their reporting and API.
Their team is investigating the issue, and we are monitoring the progress.
https://status.ads.microsoft.com/
Posted Dec 04, 2025 - 16:08 UTC
This incident affected: Data (Microsoft), Reports (Microsoft), Optimization (Microsoft), and Automated Actions (Microsoft).