Microsoft Ads API Delays

Incident Report for Skai

Resolved

A Microsoft Advertising API issue caused delays in receiving performance data reports.
This issue was resolved and all Microsoft Advertising daily reports were processed.
Posted May 14, 2025 - 19:24 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 14, 2025 - 13:46 UTC

Identified

We identified an issue with retrieving performance data from Microsoft Ads platform. Our developers have already sent an inquiry to Microsoft support.
Note that this issue is affecting only a few of our customers and not all.
Posted May 14, 2025 - 13:22 UTC
This incident affected: Data (Microsoft), Reports (Microsoft), Optimization (Microsoft), and Automated Actions (Microsoft).